Heartbleed Bug Susceptibility

HeartbleedYou may have read or received information concerning the “Heartbleed Bug”, a vulnerability in the OpenSSL cryptographic library which is used by roughly two-thirds of all websites on the Internet. BNC’s web servers do not use OpenSSL. In addition, BNC has verified that websites hosted by BNC’s service providers are not vulnerable to the Heartbleed Bug. BNC still encourages customers to use precautions to protect themselves by frequent password changes, securing confidential information, using anti-virus and anti-malware products, avoiding suspect websites, and ignoring and deleting any emails from unknown entities. If you are concerned whether or not any of the websites you use are affected by the Heartbleed Bug, you can use the following Security check tool from LastPass.

Leave a Reply